Обновления в SSL-сертификатах Let’s Encrypt: что может измениться

04.10.2021
 Обновления в SSL-сертификатах Let’s Encrypt: что может измениться

Производитель популярных бесплатных SSL-сертификатов Let’s Encrypt перестал поддерживать старую версию корневого сертификата. С 1 октября компания отказалась от DST Root CA X3 в пользу полного перехода на более современный ISRG Root X1. Что это значит для владельцев сайтов и их посетителей?

Во-первых, большинство интернет-пользователей вообще не заметит никаких изменений. Трудности могут возникнуть у тех, кто использует устаревшие версии браузеров и операционных систем — в этом случае можно увидеть стандартное предупреждение о том, что интернет-ресурс является небезопасным из-за отсутствия на нем SSL-защиты.

Сложности могут появиться и у ресурсов, которые используют API. В частности, обновления могут вызвать проблемы работы некоторых плагинов. Чтобы этого не произошло, необходимо убедиться в поддержке всех клиентов API корневого сертификата ISRG Root X1. Либо перейти на коммерческий SSL — например GeoTrust RapidSSL. Такие сертификаты пользуются еще большим доверием у пользователей и совместимы с 99% устройств и операционных систем. С полным перечнем доступных сертификатов можно ознакомиться по ссылке.

Если у вас возникнут сложности с выбором оптимального SSL-сертификата для защиты сайта, наши специалисты с удовольствием вас проконсультируют по телефону +375 17 239-57-02 или по запросу на info@hoster.by.

Сайт hoster.by собирает неперсонифицированные данные о пользователях посредством cookies-файлов, чтобы оказывать услуги с высокой степенью качества. Также мы работаем с персональными данными пользователей, которые храним и обрабатываем в соответствии с законодательством о работе с персональными данными. Как это происходит можно узнать в документах Политика конфиденциальности и Политика работы с персональными данными.